任务单 #32320

COM flow with control : missing data in log file

开放日期: 2013-10-23 21:04 最后更新: 2013-10-23 21:04

报告人:
属主:
(无)
类型:
状态:
开启
组件:
里程碑:
(无)
优先:
5 - Medium
严重性:
5 - Medium
处理结果:
文件:
Vote
Score: 0
No votes
0.0% (0/0)
0.0% (0/0)

Details

I click the "Tera Term" on the starup menu, and then the "New Connection" dialog is shown.
Specify Serial, port COM1
From menu launch: serial port setup "Setup"/"Serial port"
Baud rate:115200
Data; 8bit
Parity:none
Stop : 1bit
Flow control: hardware
-> Accept changes ( press "OK")
//Start log:
From menu launch log: "File\log"
provide a new log file name ( ex: toto.bin)
In option panel : select Binary, unselect append
-> Accept changes (press "OK" )
A second windows appears named: "Tera Term: Log"
receive 400kB
(use a device which send a known pattern or connect a cable between COM1 & COM2 and send file to COM2)
In windows "Tera Term: Log", press "Pause"
In windows "Tera Term: Log", press "Close"

Compare data sent to log(toto.bin).
-> some data is missing in log file

任务单历史 (3/4 Histories)

2013-10-23 21:04 Updated by: fred_paris
  • New Ticket "COM flow with control : missing data in log file " created
2015-03-19 00:01 Updated by: None
评论

I confirm having the same issue over a TCP/IP connexion with the service "other" on a Win64 machine. The problem seems to be worse if I try sending a binary file (File->Send file) at the same time I log binary data received.

2015-03-19 00:04 Updated by: None
评论

Side note with the previous comment. I also validated with Wireshark the data received on the TCP port with the "Analyze->Follow TCP stream" and all data appears in the stream contrary to the TeraTerm log.

2015-07-31 21:53 Updated by: None
评论

I have nearly the same issue here. I'm using TeraTerm 4.8.5 under Windows 7 (64 bit). Whenever I block the TeraTerm window by moving with the mouse, the hardware flow control becomes active and the log file loses a few characters. I have verified that the computer sending the data really stops the transmission if RTS goes high, still the TeraTerm log loses characters. If I don't block the TeraTerm main window (so the RTS/CTS lines do not get active) , the log file is completely OK also with binary files.

Attachment File List

No attachments

编辑

You are not logged in. I you are not logged in, your comment will be treated as an anonymous post. » 登录名