任务单 #39187

Hardware Flow Control

开放日期: 2019-05-03 09:14 最后更新: 2019-12-10 19:02

报告人:
属主:
(无)
类型:
状态:
开启
组件:
里程碑:
(无)
优先:
5 - Medium
严重性:
5 - Medium
处理结果:
文件:
Vote
Score: 0
No votes
0.0% (0/0)
0.0% (0/0)

Details

Hardware flow control in serial port setup does not work. Using CTS and RTS. I have tested this with other terminal programs including Hyperterminal and it is working. Something is wrong with Teraterm.

任务单历史 (3/9 Histories)

2019-05-03 09:14 Updated by: ckeays
  • New Ticket "Hardware Flow Control" created
2019-06-06 19:10 Updated by: ckeays
评论

Reply To ckeays

Hardware flow control in serial port setup does not work. Using CTS and RTS. I have tested this with other terminal programs including Hyperterminal and it is working. Something is wrong with Teraterm.

no response?

2019-06-07 19:49 Updated by: (del#24082)
评论

Hi ckeays,

I am sorry for the inconvenience caused.
I have some question.

Q1. What cable do you use? FTDI(genuine)?
Q2. What adapter do you use? CH340G USB serial converter?

I am looking forward to hearing from you.

2019-06-07 21:44 Updated by: ckeays
评论

Reply To yutakapon

Hi ckeays,

I am sorry for the inconvenience caused.
I have some question.

Q1. What cable do you use? FTDI(genuine)?
Q2. What adapter do you use? CH340G USB serial converter?

I am looking forward to hearing from you.

>

Yes i have tried a genuine FTDI cable, a CH340G installed on an atmega development board, and just regular DB9 serial port straight through cable connected to a real serial port on my computers' motherboard. None of them are working with Teraterm hardware flow control, however they all work with other terminal programs that support hardware flow control.

I have tested only in windows 32 bit and 64 bit systems.

2019-06-07 21:50 Updated by: (del#24082)
  • 属主 Update from (无) to yutakapon
2019-06-08 12:42 Updated by: (del#24082)
评论

ckeays への返信

Thank you for your information.
It seems that your problem is not Tera Term but USB driver problem.

I do not know root cause of your problem. However, I
found a suspicious place in the source code. I am not sure,
but I think the device driver of CH340G has any problem because the
flow control of Tera Term has not changed for a long long time.
So, I fixed the place experimentally.
Would you please test by using below archive if your problem is
reproduced?

https://ja.osdn.net/projects/ttssh2/storage/snapshot/snapshot-r7741-20190607-yutaka-hardware_flow.zip
I am looking forward to hearing from you.

2019-06-11 20:06 Updated by: (del#24082)
  • 组件 Update from (无) to Tera Term
2019-07-09 19:47 Updated by: (del#24082)
评论

Hi ckeays,

I apologize for the urgency, but I am still expecting your respoinse regarding my archive testing.

Please let me know if you have any questions.

2019-12-10 19:02 Updated by: (del#24082)
  • 属主 Update from yutakapon to (无)

Attachment File List

No attachments

编辑

You are not logged in. I you are not logged in, your comment will be treated as an anonymous post. » 登录名