任务单 #39243

I see no differrence when hardware flow control is enabled or not

开放日期: 2019-05-15 20:55 最后更新: 2019-12-10 19:01

报告人:
属主:
(无)
类型:
状态:
开启
组件:
里程碑:
(无)
优先:
5 - Medium
严重性:
5 - Medium
处理结果:
文件:
Vote
Score: 0
No votes
0.0% (0/0)
0.0% (0/0)

Details

TeraTerm version 4.102 7452
Windows 10 Pro Version 10.0.17763 Build 17763

I am using TeraTerm connected to an embedded device 2 wires Rx/Tx UART through FTDI chip (for RS232 - USB conversion).
When I send string "test" from the embedded UART, it is received and displayed by TeraTerm even is hardware flow control is enabled whereas I would expect no char is received when flow control is enabled.
It is a bug, isn't it ?

任务单历史 (3/7 Histories)

2019-05-15 20:55 Updated by: chrdou
  • New Ticket "I see no differrence when hardware flow control is enabled or not" created
2019-06-07 20:49 Updated by: (del#24082)
评论

Hi chrdou,

I am sorry for the inconvenience caused.
I have some question.

Q1. What cable do you use? FTDI(genuine)?
Q2. Is the the FTDI chip you use made of CH340G ?

I am looking forward to hearing from you.

2019-06-07 21:50 Updated by: (del#24082)
  • 属主 Update from (无) to yutakapon
2019-06-07 23:00 Updated by: chrdou
评论

Hi yutakapon,

Q1 : connection through I/O buffers (SN74AVC4T245D, SN74AVC1T45DBVR, SN74AVC1T45DBVR) on a PCB

Q2 : FT2232D

Another interesting test (with exactly the same results) I performed since this ticket creation is connecting 2 Dell PCs D630 and D620 (WinXP) with DB9 COM port direct connection via a null-modem cable with full handshaking (https://www.lammertbies.nl/comm/info/RS-232_null_modem.html#full).

Simpler and more HW reliable.

(Edited, 2019-06-07 23:02 Updated by: chrdou)
2019-06-08 12:53 Updated by: (del#24082)
评论

chrdou への返信

Thank you for your response.
I have one more question.

Q3. Do you connect to serial device with DSR/DTR?

So, Tera Term supports RTS/CTS only. If you use DSR/DTR,
the hardware flow of Tera Term does not work well.

Next, when you use RTS/CTS, I think that your problem is
USB serial dreiver.

I do not know root cause of your problem. However, I
found a suspicious place in the source code. I am not sure,
but I think the device driver of USB serial has any problem because the
flow control of Tera Term has not changed for a long long time.
So, I fixed the place experimentally.
Would you please test by using below archive if your problem is
reproduced?

https://ja.osdn.net/projects/ttssh2/storage/snapshot/snapshot-r7741-20190607-yutaka-hardware_flow.zip
I am looking forward to hearing from you.

2019-06-11 20:06 Updated by: (del#24082)
  • 组件 Update from (无) to Tera Term
  • 严重性 Update from 8 to 5 - Medium
  • 优先 Update from 8 to 5 - Medium
2019-12-10 19:01 Updated by: (del#24082)
  • 属主 Update from yutakapon to (无)

Attachment File List

No attachments

编辑

You are not logged in. I you are not logged in, your comment will be treated as an anonymous post. » 登录名