Amit Langote
amitl****@gmail*****
2013年 7月 31日 (水) 21:40:10 JST
On Wed, Jul 31, 2013 at 9:22 PM, Fujii Masao <masao****@gmail*****> wrote: > On Wed, Jul 31, 2013 at 9:07 PM, Amit Langote <amitl****@gmail*****> wrote: >> On Wed, Jul 31, 2013 at 8:47 PM, Beena Emerson <memis****@gmail*****> wrote: >>> Hi all, >>> >>> I have not checked the entire patch. >>> >>> I just wanted to bring to notice that with the patch applied, both pg_trgm >>> and pg_bigm cannot co-exist in the database as they now have same definition >>> for many functions like similarity, show_limit, set_limit, etc. >>> >>> >> >> Oh, wondering if something like defining a schema say 'pg_bigm' and >> qualifying such conflicting names with the schema name would work. >> Thoughts? > > Doesn't this make the usability of pg_bigm worse? For example, a user of pg_bigm > always needs to specify the 'pg_bigm' schema name when using pg_bigm. > Hmm, yes it does. In that case, we'd need to change the names of those functions, no? I am afraid this also applies to the operator '%' which seems to be even worse a case. -- Amit Langote