• R/O
  • HTTP
  • SSH
  • HTTPS

标签
No Tags

Frequently used words (click to add to your profile)

javac++androidlinuxc#windowsobjective-ccocoa誰得qtpythonphprubygameguibathyscaphec計画中(planning stage)翻訳omegatframeworktwitterdomtestvb.netdirectxゲームエンジンbtronarduinopreviewer

A fast implementation of the Nix expression language


File Info

Rev. 376831c93fc2872a6134b52fd5bec158805e195f
大小 1,410 字节
时间 2024-06-10 07:57:27
作者 Corbin
Log Message

parser: Add weird let-expression and rec-expression.

Content

{
  description = "Packages built with RPython";

  inputs = {
    nixpkgs.url = "github:nixos/nixpkgs/release-23.05";
    flake-utils.url = "github:numtide/flake-utils";
    rpypkgs = {
      url = "github:rpypkgs/rpypkgs";
      inputs = {
        nixpkgs.follows = "nixpkgs";
        flake-utils.follows = "flake-utils";
      };
    };
  };

  outputs = { self, nixpkgs, flake-utils, rpypkgs }:
    let
      # The systems where RPython has been tested to work.
      testedSystems = [
        "x86_64-linux"
        "aarch64-linux"
      ];
    in flake-utils.lib.eachSystem testedSystems (system:
      let
        pkgs = import nixpkgs {
          inherit system;
          # Not free for corporate use!
          config.allowUnfree = true;
        };
        regiux = rpypkgs.lib.${system}.mkRPythonDerivation {
          entrypoint = "main.py";
          binName = "main-c";
          binInstallName = "rix";
          optLevel = "2";
          withLibs = ls: with ls; [ appdirs rply ];
        } {
          pname = "regiux";
          version = "2024";

          src = ./.;

          meta = {
            description = "A fast implementation of the Nix expression language";
            license = pkgs.lib.licenses.cc-by-nc-sa-40;
          };
        };
      in {
        packages.default = regiux;
        devShells.default = pkgs.mkShell {
          packages = [];
        };
      }
    );
}